Getting Started with the Reporting Suite for Kepler

Reporting Suite includes:

   Reporting
   Workflow Run Manager
   Provenance
   Tagging

Reporting 2.1.0

May 20, 2010
Getting Started with the Reporting Suite for Kepler

The ‘Getting Started with the Reporting Suite’ guide is a tutorial style manual for scientists who would like to use the Reporting suite for Kepler. The Reporting suite contains four modules. These are: Reporting, the Workflow Run Manager, Provenance, and Tagging. The Reporting suite was created to assist scientists in generating reports from Kepler workflows, and in capturing and managing the results of workflow executions.

Table of Contents

1. Introduction .................................................................................................................. 2
   1.1 What is the Reporting Suite ? ........................................................................... 2
2. Downloading and Installing the Reporting Suite ............................................. 3
3. Basic Components of the Reporting Suite ....................................................... 3
   3.1 Navigation between Workflow and Reporting Views ................................. 3
   3.2 The Workflow Run Manager Interface ....................................................... 3
   3.3 The Workflow Tagging Interface ................................................................. 3
4. The Report Designer Interface ............................................................................. 4
   4.1 Adding and Deleting Workflow Items from a Report Layout .................. 4
   4.2 Labeling Dynamic Report Items ............................................................... 5
   4.3 Adding and Deleting Formatting Items for a Report .............................. 6
   4.4 Arranging Items in a Report ....................................................................... 7
   4.5 Setting Report Item Properties ................................................................. 7
   4.6 ‘Locking the Report Layout .................................................................... 7
5. Generating the Report .......................................................................................... 8
6. The Report Viewer ............................................................................................... 8
7. Tutorial: How to create a Report ..................................................................... 8

1. Introduction
The Getting Started with the Reporting Suite guide introduces the main components and functionality of the Reporting Suite. The Reporting Suite is used in conjunction with Kepler, a software application for the analysis and modeling of scientific data. There are four modules that comprise the Reporting Suite. These modules are: Reporting, the Workflow Run Manager, Provenance, and Tagging. This Guide provides a brief introduction to the Reporting Suite interface, and provides some guidance on how to use the features of the Reporting suite to create reports, manage workflows, tag workflows and runs, and export workflow the results of workflow executions (“runs”).

1.1 What is the Reporting Suite ?
The Reporting Suite adds additional features to the Kepler application. The Reporting Suite provides scientists with a way to create reports from their Kepler workflows, tag workflows, and tag, search, export, upload and delete workflow runs.
2. **Downloading and Installing the Reporting Suite**

From the main Kepler Menus select Tools > Module Manager. From the Module Manager dialog, select the Available Modules tab. Select ‘reporting-2.1.0’ from the list of Available Suites, then click the right arrow button to move the reporting-2.1.0 suite to the list of Selected Modules. Click the ‘Apply and Restart’ button to retrieve the reporting suite and restart Kepler. When Kepler has been restarted you will see that the Current Suite shows four modules – reporting, workflow-run-manager, tagging, and provenance. This indicates that the Reporting suite has been installed successfully.

3. **Basic Components of the Reporting Suite**

Once you have installed the Reporting suite, you will notice that the Kepler interface now has some new items at the top of the toolbar. The View dropdown selection box allows you to switch between the Workflow Editor view, and the Report Designer view. The Tagging selection box allows you to semantic tag your workflows and workflow runs.

3.1 **Navigation between Workflow and Reporting Views**

When the Reporting suite is installed, Kepler will always start in the Workflow Editor view. After you build your workflow, then switch to the Report Designer view by selecting it from the View drop down selection box in the upper right hand corner of the Kepler toolbar. You can move back and forth between the views without losing any of the workflow or report layout information.

3.2 **The Workflow Run Manager Interface**

The Workflow Run Manager interface allows you to track and manage executions of Kepler workflows. A report for a workflow run, if it exists, can be viewed by clicking on the run’s row in the Workflow Run Manager table. For more information on using the Workflow Run Manager, please refer to the documentation for the Workflow Run Manager. This documentation can be accessed by selecting Help > Modules Documentation, and then select ‘workflow-run-manager’ from the list of active modules.

3.3 **The Workflow Tagging Interface**

The Workflow Tagging Interface allows you to semantic tag Kepler workflows and workflow runs. For more information on using the Tagging module, please refer to the documentation for Tagging. This documentation can be accessed by selecting Help > Modules Documentation, and then select ‘tagging’ from the list of active modules.
4. The Report Designer Interface
The Report Designer interface allows you to create reports based on your workflow.

After you have opened or created your workflow, switch to the Report Designer view to create a report. In the Report Designer view, you will see three groups of components in the left hand side of the pane. These are as follows:
1.) Items of Interest
2.) Report Formatting Items
3.) Item Properties

The right hand side of the Report Designer Interface contains the tabs for creating and viewing the Report Layout, and the Workflow Run Manager.

4.1 Adding and Deleting Workflow Items for a Report

The ‘items of interest’ represent the actors and other elements from your workflow that may be added to your report. The values that are generated for these items are not available until after the workflow is run. Therefore, you can think of these as ‘dynamic’
items that are synonymous with elements of the workflow and the data that will be generated each time a workflow runs.

To add a dynamic workflow item to the report, simply drag it out from the tree in the items of interest group, and onto the report layout area.

The report layout area is designated by an image of a blank report labeled with the words “Drag items here to create a report”. Once you drop the item of interest into the layout area, a representation of that item will be displayed in the report layout.

To delete any report item, simply click on the red ‘Delete’ icon on the right hand side of the item.

4.2 Labeling Dynamic Report Items

If you would like to apply a label to any dynamic report item, there are four fields that allow you to create a label that will appear to the North, South, West, or East of that specific item. This is useful for creating figure maps, or other short annotations. For longer annotations, it is best to use the static text field that is available in the report formatting items group as described in the next section.
4.3 Adding and Deleting Formatting Items for a Report

In addition to the dynamic items from your workflow, you can also add formatting to your report by dragging and dropping the report formatting icons into your report layout. Report formatting items include the following:

By dragging and dropping the section icon into your report layout, you can add a section heading. Section headings contain text for the title of the section and a line below the text.

By dragging and dropping the horizontal rule icon into your report layout you can add a horizontal line between items on your report.

By dragging and dropping the text icon into your report layout you can add basic text annotations to your report.

By dragging and dropping the image icon into your report layout you can add a static image from an external file.
To delete any report formatting item, simply click on the red 'Delete' icon on the right hand side of each item.

### 4.4 Arranging Items in a Report

After you drag and drop the dynamic workflow items and static report formatting items into your report layout, you can then re-arrange the layout by dragging and dropping the items in the report layout area. You can do this by placing the mouse over any corner or edge of a report item in the report layout, until you see the cursor change into the directional crosshair cursor. Click the left mouse button and the report item that you are hovering over will change to a darker color, indicating that the report item has been selected. Use your mouse to drag the item into any blank white space between items. You will see a green 'plus' icon appear. Then release the mouse button and the item will be moved into the area where you have just dropped it. All of the items in the report layout can be arranged using drag and drop.

### 4.5 Report Item Properties

Each report item has properties that control the formatting values for the item that is currently selected. To select the item you would like to assign property values to, click the left mouse button on the item. The selected report item will change to a darker color blue, and the properties window will display the list of configurable properties for that item. Next, click the left mouse button in the Value column located just to the right of the property that you would like to set. A text entry box with two arrows will be displayed. Clicking anywhere on the two arrows, will bring up a list of possible value settings for that property. Click on any of the values in the list to assign it as the value for that property.

![Properties Window](image)

### 4.6 ‘Locking’ the Report Layout

If you have installed the Workflow Run Manager module in addition to the reporting module, it will provide the ability to track and manage workflow runs. A report layout (if it exists) associated with a workflow run can be viewed by clicking on a run row in the Workflow Run Manager table. If you currently have a report layout designed but unsaved, and you click on a run row, you could lose these changes when the workflow
run manager switches to the report layout for this run. Checking the ‘Lock edit mode’ box will prevent this. When the ‘Lock edit mode’ box is checked, the Report Designer will not load past report layouts associated with runs, thus enabling you to operate on run rows without losing your unsaved report layout.

5.0 Generating the Report
After you have completed your report layout you will need to run your workflow in order to generate a report. Use the Kepler ‘Run’ button to initiate your workflow run. While your workflow is running status messages will be displayed in the bottom left hand portion of the Kepler interface. After the run is complete, you will see a status message that reads ‘execution finished.’ You can then use the Report Viewer interface to view your report.

6.0. The Report Viewer
After you have created a report layout, and run your workflow, you can click on the ‘Report Viewer’ tab to view your report. You can switch between the Report Designer tab and the Report Viewer tab to make changes to your report layout and then view those changes. Using the ‘Refresh (using current layout)’ button, will allow you to enact these changes without having to re-run the workflow.

7.0 Tutorial: How to Create a Report
To create a report from a Kepler workflow simply use the following steps.

1.) Open a Kepler workflow or create a new one.
2.) Switch to the Report Designer view.
   Use the view menu located in the upper right hand corner of the Kepler toolbar to switch to the Report Designer view.
3.) Drag and Drop the dynamic workflow items onto the Report Designer canvas.
   From the Items Of Interest panel, drag dynamic report items onto the Report Designer canvas into the area that reads ‘Drag items here to create a report.’
4.) Arrange the dynamic workflow items into any sequence by dragging and dropping them above or below one another.
5.) Add the report formatting items that you would like to include in your report.
   This is done by dragging and dropping them onto the Report Designer canvas.
   Arrange them in whatever sequence you would like by dragging them above or below the dynamic workflow items to finish creating your report layout.
6.) Run the Workflow. Once your report layout is finished, you must run the workflow at least once in order to view your report.
7.) View your Report. Click on the Report Viewer tab to view your report.
8.) Export the KAR archive with the Report and Report Layout. Right click on the relevant run in the workflow run manager and select “Export Archive...” to save your workflow, report layout, report instance, and run metadata into a KAR archive.