Getting Started with the Reporting Suite for Kepler

The Reporting suite was created to assist users in generating reports from Kepler workflows, and in capturing and managing the results of workflow executions.

Table of Contents

1. Introduction ........................................................................................................................................ 2
   1.1 What is the Reporting Suite? ........................................................................................................ 2

2. Downloading and Installing the Reporting Suite ............................................................................ 3

3. Basic Components of the Reporting Suite .......................................................................................... 3
   3.1 Navigation between Workflow and Reporting Views ................................................................. 3
   3.2 The Reporting Interface .............................................................................................................. 3
   3.3 The Workflow Run Manager Interface ........................................................................................ 3
   3.4 The Tagging Interface ................................................................................................................ 4
   3.5 The Workflow Scheduler GUI .................................................................................................... 4

4. The Report Designer .......................................................................................................................... 5
   4.1 Adding and Deleting Workflow Items of Interest .................................................................... 5
   4.2 Labeling Dynamic Report Items ............................................................................................... 6
   4.3 Adding and Deleting Report Formatting Items ......................................................................... 7
   4.4 Arranging Items in a Report ........................................................................................................ 7
   4.5 Report Item Properties ............................................................................................................... 7

5.0 Generating the Report ...................................................................................................................... 8

6.0. The Report Viewer ........................................................................................................................ 8

7.0 Tutorial: How to Create a Report .................................................................................................... 8

1. Introduction

The Getting Started with the Reporting Suite guide introduces the main components and functionality of the Reporting Suite. The Reporting Suite is used in conjunction with Kepler, a software application for the analysis and modeling of scientific data. It is comprised of five modules: Reporting, the Workflow Run Manager, Provenance, Tagging, and the Workflow Scheduler GUI. This guide provides a brief introduction to the Reporting Suite interface, and provides some guidance on how to use its features to create reports, and manage and tag workflows and past executions (“runs”). For more details on any of the component suites, please refer to that suite’s documentation by selecting Help => Modules Documentation.

1.1 What is the Reporting Suite?

The Reporting Suite adds additional features to the Kepler application. It provides users a way to create reports from Kepler workflows, tag workflows, and tag, search, export, import, upload and delete workflow runs.
2. Downloading and Installing the Reporting Suite
From the main Kepler menu select Tools => Module Manager. From the Module Manager dialog, select the Available Modules tab. Select ‘reporting-2.5’ from the list of Available Suites, then click the right arrow button to move reporting-2.5 to the list of Selected Modules. Click the ‘Apply and Restart’ button to download and restart Kepler into the Reporting suite.

3. Basic Components of the Reporting Suite
Once you have installed the Reporting suite, you will notice that the Kepler interface has some new items at the top of the toolbar. The View dropdown selection box allows you to switch between the Workflow, Reporting, and Profiling views. The Workflow Run Manager allows you to manage your past workflow runs. The Tagging toolbar allows you to semantically tag your workflows and workflow runs. Tagging also provides a Tag Manager accessible from Tools menu. The Workflow Scheduler is also accessible from the Tools menu.

3.1 Navigation between Workflow and Reporting Views
When the Reporting suite is installed, Kepler will start in the Workflow view. You can switch to the Reporting view by selecting it from the View drop-down in the upper right hand corner of the Kepler toolbar. You can move back and forth between views without losing any workflow or report design information.

3.2 The Reporting Interface
The Reporting view allows you to design and view reports for your workflows. The Report Designer is used to create a report design, and the Report Viewer will display the generated report instance after workflow execution.

3.3 The Workflow Run Manager Interface
The Workflow Run Manager allows you to track and manage executions (“runs”) of Kepler workflows. If a run has an associated report design and report instance, they can be viewed by clicking on the run-row in the Workflow Run Manager table.

For more information on using the Workflow Run Manager, please refer to its documentation by selecting it from Help => Modules Documentation.
3.4 The Tagging Interface
Tagging allows you to semantically annotate Kepler workflows and workflow runs. Pre-existing tags may be chosen from the drop-down, or you may type in your own in the Tagging toolbar text field.

For more information on using Tagging, please refer to its documentation by selecting it from Help => Modules Documentation.

3.5 The Workflow Scheduler GUI
The Workflow Scheduler GUI provides an interface for scheduling workflow execution on a remote server (kepler-project.org by default). Workflows may be executed periodically. If your workflow has an associated report design, a resultant run-kar will be created that contains the generated report instance when the workflow is executed, and the Scheduler allows you to configure where this run-kar is placed (the Kepler Repository by default).

For more information on using the Workflow Scheduler, please refer to its documentation by selecting it from Help => Modules Documentation.
4. The Report Designer
The Report Designer allows you to design reports for your workflows.

After you have opened or created a workflow, switch to the Reporting view to create a report design. On the Report Designer tab, you will see three groups of components on the left hand side of the window. From top to bottom, these are: Items of Interest, Report Formatting Items, and Item Properties.

The right hand side of the window contains tabs for switching between the Report Designer and Report Viewer. The Workflow Run Manager is seen at bottom, and may be used to browse past report designs and instances.

4.1 Adding and Deleting Workflow Items of Interest
The ‘Items of Interest’ represent the actor ports and other elements from your workflow that may be added to your report. The values that are generated for these items are not available until after the workflow is run. Therefore, you can think of these as ‘dynamic’ items that are synonymous with elements of the workflow and the data that will be generated each time a workflow runs.

To add a dynamic Items of Interest workflow item to the report, simply drag it out from the tree and onto the report design layout area.
The report layout area is initially designated by an image of a blank report labeled with the words “Drag items here to create a report”. Once you drop the item of interest into the layout area, a representation of that item will be displayed in the report layout.

To delete any report item, simply click the red ‘Delete’ icon in the upper-right of the item.

4.2 Labeling Dynamic Report Items
If you would like to apply a short label to any dynamic report item, there are four fields that allow you to create a label that will appear to the Top, Bottom, Left, or Right of that item. For longer annotations, it is best to use the static text field that is available in the Report Formatting Items group, described in the next section.
4.3 Adding and Deleting Report Formatting Items
You can add formatting to your report by dragging and dropping report formatting items into your report layout. Report formatting items include:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="section" /> section</td>
<td>Section Heading — text for the title of the section with a line beneath.</td>
</tr>
<tr>
<td><img src="image" alt="hr" /> hr</td>
<td>Horizontal Rule — a horizontal line between report items.</td>
</tr>
<tr>
<td><img src="image" alt="text" /> text</td>
<td>Text — basic text annotations.</td>
</tr>
<tr>
<td><img src="image" alt="image" /> image</td>
<td>Image — a static image from an external file.</td>
</tr>
</tbody>
</table>

To delete any report formatting item, click the red ‘Delete’ icon in the upper-right of each item.

4.4 Arranging Items in a Report
After you design a report, you can re-arrange its layout by dragging and dropping the items in the report design layout area. You can do this by placing the mouse over any corner or edge of a report item in the report layout, until you see the cursor change into the directional crosshair cursor. Click the left mouse button and the report item that you are hovering over will change to a darker color, indicating that the report item has been selected. Use your mouse to drag the item into any blank white space between items. You will see a green ‘plus’ icon appear. Release the mouse button and the item will be dropped into the new location.

4.5 Report Item Properties
Each report item has properties that control its formatting. To select the item you would like to format, click the left mouse button on the item. The selected report item will change to a darker color, and the properties window will display the list of configurable properties for that item. Next, click the left mouse button in the Value column located just to the right of the property that you would like to set. A text entry box with two arrows will be displayed. Clicking anywhere on the two arrows, will bring up a list of possible value settings for that property. Click on any of the values in the list to assign it as the value for that property.
5.0 Generating the Report

After you have completed your report layout you will need to run your workflow to generate a report. Use the Kepler 'Run' button to execute your workflow. While your workflow is running status messages will be displayed in the bottom left hand portion of the Kepler interface. When execution is complete, you will see a status message that reads ‘execution finished.’ You can then use the Report Viewer to view your generated report.

6.0. The Report Viewer

After you have created a report layout, and run your workflow, you can click on the 'Report Viewer' tab to view your report. You can switch between the Report Designer tab and the Report Viewer tab to make changes to your report layout and then view those changes. Using the ‘Refresh (using current layout)’ button, will allow you to enact these changes without having to re-run the workflow.

7.0 Tutorial: How to Create a Report

To create a report from a Kepler workflow:

1.) Open a Kepler workflow or create a new one.
2.) Switch to the Reporting view.
   Use the view menu located in the upper right hand corner of the Kepler toolbar to switch to Reporting.
3.) Drag and Drop dynamic workflow items onto the Report Designer canvas.
   From the Items Of Interest panel, drag dynamic report items (e.g. actor ports) onto the Report Designer canvas.
4.) Arrange the dynamic workflow.
   Item order may be changed by dragging and dropping items above or below one another.
5.) Add report formatting items.
   Drag any drop any Report Formatting Items you would like in your report.
6.) Run the Workflow.
Once your report layout is finished, run the workflow at least once in order to view your report.

7.) **View your Report.**
   Click on the Report Viewer tab to view your report.

8.) **Export the run-KAR archive.**
   If you would like to share or permanently save this workflow, report design, report instance, and WorkflowRun metadata, right-click on the run in the workflow run manager and select “Export Archive...”.